API down

Incident Report for Be My Eyes

Resolved

We have confirmed that all Be My Eyes services are now fully operational, and call routing has stabilized.

The platform has returned to normal performance levels, and our monitoring confirms sustained stability over the past period.

Thank you for your patience and understanding while our team worked to restore service.
Posted Oct 20, 2025 - 20:23 UTC

Monitoring

We are pleased to report that call routing has returned to nominal levels.
Our team continues to monitor performance closely to ensure ongoing stability.
Posted Oct 20, 2025 - 18:53 UTC

Update

The situation continues to improve steadily.
We can confirm that a solid number of calls have been successfully routed in the past five minutes, indicating that recovery is progressing.

Our team will continue to monitor performance closely and share another update as soon as we confirm full service restoration.
Posted Oct 20, 2025 - 18:47 UTC

Update

Our vendor has reported decreasing network connectivity issues in the US-EAST-1 region.

We are also observing significant improvements in call routing on the Be My Eyes platform. However, some calls are still failing intermittently as recovery continues.

Our engineering team is monitoring performance closely and will provide another update as soon as we see full stability.
Posted Oct 20, 2025 - 18:34 UTC

Identified

The vendor reported that they are in the process of validating a fix and will deploy to the first Availability Zone as soon as they have confidence they can do so safely.
Posted Oct 20, 2025 - 17:30 UTC

Update

Our third-party vendor is working to restore full service performance. This is a multi-cloud general issue affecting various infrastructure globally.
Posted Oct 20, 2025 - 17:03 UTC

Investigating

We are currently experiencing an infrastructure issue affecting database availability. The issue appears to be related to a broader service disruption in the US-EAST-1 region. Our engineering team is actively working to restore normal operations as quickly as possible.
We’ll share updates as more information becomes available.
Posted Oct 20, 2025 - 16:11 UTC
This incident affected: API.